Dockerfile - Tensorflow add-ons error

hi, I am getting below error while deploying Rasa Open Source on server using Dockerfile. Can you please help to resolve? rasa version : 1.10.10 Python : 3.6 Error Could not find a version that satisfies the requirement tensorflow-addons<0.9,>=0.8 (from rasa==1.8.0->-r requirements.txt (line 1)) (from versions: )

No matching distribution found for tensorflow-addons<0.9,>=0.8 (from rasa==1.8.0->-r requirements.txt (line 1))

Hi @poojadeshmukh. Which Rasa version are you using?

@Juste, I am using Rasa 1.10.10 . When I used rasa core == 0.11.2 it worked. but can you please help on this issue? as I need to work on 1.10.10.

What is the difference in using rasa==1.10.10 and using rasa core==0.11.2 in docker file?

After using rasa core==0.11.2, it worked but now I am stuck at below issue:

In our orgaisation, we are using Openshift and Jenkins pipeline for deployment. I have my pipeline created, and I have docker and docker-compose.yml files in my bit-bucket repository.

We are not using Rasa-X, its Rasa Open Source with customized UI.

Currently, I am stuck at pytest.ini and getting below error. Can you please help to resolve the issue? What should be the contents of pytest.ini?

Successfully installed coverage-5.3 iniconfig-1.1.1 pluggy-0.13.1 py-1.9.0 pytest-6.1.2 pytest-cov-2.10.1 toml-0.10.2

  • ‘[’ -d tests ‘]’
  • python -m pytest

============================= test session starts ==============================

platform linux – Python 3.6.9, pytest-6.1.2, py-1.9.0, pluggy-0.13.1

rootdir: /pathof rootdir, configfile: pytest.ini

plugins: cov-2.10.1

collected 0 items

============================ no tests ran in 0.04s =============================

script returned exit code 5