Docker compose - set cors header

Hello,

I was following the guide from the docs on how to use the docker-compose yaml file. But I need to set the cors headers.
When I am on my windows machine I usualls do this by running this command: run --enable-api --cors "*".
However using this adaption of the file from the tutorial, I get a rasa: error: invalid choice: 'run --cors "*"' (choose from 'init', 'run', 'shell',...) error.

My docker-compose.yaml:

version: '3.0'
services:
  rasa:
    image: andileni/v1
    ports:
      - 5005:5005
    volumes:
      - ./:/app
    command:
      - run --enable-api --cors "*"
  action_server:
    image: rasa/rasa-sdk:latest
    volumes:
      - ./actions:/app/actions

Are there any recommendations for solving this issue?

Kind regards Andi

I solved this by putting this up like this

image

Good luck

This works, thanks! :slight_smile:

1 Like