Deploying on EKS

Hi, I’ve been navigating deploying my bot onto EKS and running into difficulties. I’ve tried using the helm chart and it seemed like I did everything right, but some of my pods are stuck in pending, and others are crashing.

penelope-alpha-app-68f97699bc-x8xpz               1/1     Running            0          168m
penelope-alpha-duckling-554bb96b59-rj6lv          1/1     Running            0          168m
penelope-alpha-event-service-6484676787-5pbr2     0/1     Running            15         168m
penelope-alpha-nginx-6bbdf86ff4-q8hts             1/1     Running            2          168m
penelope-alpha-postgresql-0                       0/1     Pending            0          167m
penelope-alpha-rabbit-0                           0/1     Pending            0          168m
penelope-alpha-rasa-production-66f547c88f-2skst   0/1     CrashLoopBackOff   8          168m
penelope-alpha-rasa-worker-659b94688d-h2rm8       0/1     CrashLoopBackOff   8          168m
penelope-alpha-rasa-x-59f9cc46cf-zpct7            0/1     Pending            0          168m
penelope-alpha-redis-master-0                     0/1     Pending            0          168m

When I attempt to check the logs, it doesn’t return anything at all. kubect log --namespace [ns] [pod] returns nothing.

I also tried navigating to the nginx site, and it generates a 502 error.

Any help?

Hi Stephan,

What is the output of the command kubectl describe pod penelope-alpha-rasa-production-66f547c88f-2skst?


Oh sorry, I missed your response. I got around this changing some stuff in my values.yml file I believe.