Deploy Rasa Bot on Cloud Run

Hi there,

Just created a small example on how to deploy your chatbot on google cloud run which offers 2Gi containers in their free tier with concurrency as well as volume.

Free feel to reach out to me if you have any questions :slight_smile:

Hello souvijk, Thanks for the README file i tried following the instruction for deployment but getting error , tried a few solution e.g adding RUN CHMOD 755 +x in the Dockerfile , but still does not resolve the error

. Hope that you can help me up . Thanks

Do it in your machine. Running chmod within dockerfile won’t work.

Change permissions and then build

If you clone my repo, the permissions are already up to date

I cloned the repo from github and still facing the same error invalid Entry point ):

Changed the file’s permission on your machine first before building the docker image

Remove all images that were created earlier because it might be using docker cache

Thanks souvikg , may i know how do we clear the image in docker cache ?First time using docker here .

When you run the command docker images , you might see a lot of images with the name none, you can remove them.

docker rmi -f ID where ID is the id of the images without any names and it named as none. these might be images which is caching the layers.

After much attemp i still failed to deploy but i can see the service in cloud run I had tried giving auth. user full access control through properties and also icacls /grant Everyone:F /t

could you do an ls -ltr on the cloned repository. if it has the correct permissions it would look like this

-rwxrwxr-x 1 souvik souvik   32 Jun 10 23:44

ofcourse a different user:group for you

if not try this chmod +x ./

Hi Souvik, i am following your documentation to deploy Rasa on Cloud Run using the CICD. As soon as i commit my code in github, the build trigger fail with following error below. Can you help with this. Thanks

BUILD Starting Step #0 Step #0: Already have image (with digest): Step #0: unable to prepare context: unable to evaluate symlinks in Dockerfile path: lstat /workspace/Dockerfile: no such file or directory

Finished Step #0

Do you have the dockerfile in the correct path?

Worked perfectly for me - cloning repo, following readme (enabling cloud run, setting IAM permissions, and deploying), even with my own postgres tracker store endpoint and last rasa version (3.4)

Thanks a lot !

1 Like

If someone has an error like this: Container failed to start. Failed to start and then listen on the port defined by the PORT environment variable.

then here’s the solution: ubuntu - Docker error on an entrypoint script: “no such file or directory” - Stack Overflow

It’s about line endings :smiley: