Db container error in installing RasaX on Windows?

First of all, yes, I understand that Rasa X should typically be installed on a Linux server. However, according to the Masterclass videos, you can set up Rasa X on any Docker-supporting OS.

I’m mostly trying to understand the actual installation process and see how the features in it work (in server mode, not local, so I can try out things like IVC).

I’ve followed all the steps in the manual installation process (well, their closest Windows counterparts in any case) and the Docker containers are ALMOST all up and running.

However, a quick look at the dashboard shows that two containers, namely the db container and the rasa-x container are constantly crashing and restarting.

The logs for the rasa-x_1 container show this error, while the logs for the db_1 container just seems to be stuck on one step:

What am I doing wrong here? I’m using Rasa-X 0.25.0 and Rasa 1.7.0. (The container versions in the images aren’t accurate; I was trying out an older version to see if that makes the errors go away, but they persist in both combinations.)

Hi @ActuallyAcey,

Instead of trying to do manual installation of the docker containers, I recommend to create an Ubuntu VM on your computer, and then use the Quick Installation inside that VM.

A lightweight VM that I use a lot is multipass

Another good alternative is to use a hyper-V Ubuntu VM as described here

Arjaan wrote instructions on setting up Rasa X on Windows 10 using Hyper-V with instructions here. Can you give this a try?

@Arjaan @stephens

I mean, sure, I can. That doesn’t really answer my original question, though, and it kind of undermines the purpose of a manual Docker installation process if the only solution to problems coming from it is “Go for the quick install”.

While I try that, I would like to request a solution to the problem I AM facing right now.

@Arjaan @stephens

To update you guys, I did try on a Ubuntu VM as you mentioned. I’m getting the same error as this post, where the db and rasa-x containers are continually restarting.

Can you do a docker-compose down and then try restarting the containers as root: sudo docker-compose up -d?

Tried that. Didn’t change anything.

@ActuallyAcey,

How much memory & disk did you allocate for your VM ?

Ensure you are giving proper permissions to the db folder and other folders per the instructions here : Docker-Compose Manual Install