Couldn't connect to the server at ''

Hi, I am getting this error, when my bot is trying to execute file. Do you know what is the problem?

Couldn’t connect to the server at ‘’. Is the server running? Error: Cannot connect to host ssl:default [The format of the specified network name is invalid]

@risgrot can you please share the screenshot, and with the command you are using?

It actually worked few times, so the error is very strange… I tried everything, re-installed environment on different laptops (windows, mac) - the same issue.

@risgrot in get_weather you are using API to call, the sort that code, and you will be good to go. OR I am missing something?

I am getting the same exatly error when trying to play RPS…

@risgrot can you comment on the get_weather and share with me the RPS related error and also share the rasa --version

Do mention me @ nik202 for fast reply thanks.

@risgrot did you clone the repo or updated some code?

I am not sure what you mean. I commented weather piece of code from file.

@risgrot you copied the code as it is?

It gives the same error wherever bot calles file. It is the same with rps, weather or my own written action.

@risgrot please share me all related files.

Yes, I copied code. It is the same with any code. I am actually not able to find any working git repo RASA examples - either they are out of date or I am getting this error. I am working on a very big project and I am loosing so much time just to solve this bug. Any ideas what could be an issue? Nobody else faced it before me?

@risgrot please see this repo and check your code and fix the issue or download and run like it. GitHub - rctatman/Rasa-3.0-rock-paper-scissors-chatbot: A simple chatbot that plays rock paper scissors

Or what you are looking for rasa 3.X?

Hi, I cloned example - it is the same error

@risgrot Ok, delete all the previous trained models and train and run. Let me know the output.

Let me confirm you the code is running fine:

@risgrot Can you tell me on which OS you are working? and how you created the env?

OR can you create env again, install rasa, clone the repo, train the model and run?

@risgrot any update?

I could not make it work on Windows, but I managed on Mac. I do not have time to troubleshoot anymore, spent 1 week😬 So I just continue on Mac now… (exactly same installation steps, same version of anaconda, phython, rasa, etc…)

Thanks a lot for help!

@risgrot No worries, happy you solved it, please close this thread a solution and good luck!