Ssl:default [Connection refused]

error when run (rasa run --enable-api --cors “*” ) return error

2021-11-19 22:23:20 ERROR rasa.core.actions.action - Failed to run custom action ‘1_action_Hello’. Couldn’t connect to the server at ‘http://localhost:5056/webhook’. Is the server running? Error: Cannot connect to host localhost:5056 ssl:default [Connection refused] 2021-11-19 22:23:20 ERROR rasa.core.processor - Encountered an exception while running action ‘1_action_Hello’.Bot will continue, but the actions events are lost. Please check the logs of your action server for more information. Traceback (most recent call last):

@momen Ok! Interesting. Few pointers for you.

  1. We run this command: rasa run -m models --enable-api --cors "*" --debug for running rasa server on port 5005
  2. In the second terminal we run the command: rasa run actions --debug
  3. We create the custom action whilst using action_hello starting with action its generic syntax
  4. I guess you have changed the port of custom action to 5056 that is fine you can assign any port, as the default one is
  url: 'http://localhost:5055/webhook'

Please take care of these pointers and you will able to solve your query, If you know already then please elaborate more about your issue. Good Luck!

@nik202 thanks

@momen No worries bro :+1:. If this help you I’d would request to close this thread a solution for yourself and for others.

@momen Do the pointers helped you? is this a error still?

@nik202 yes this error is solved. how can add Multilingual response in domain.yml

@momen please close this thread and create a new thread of your new issue as

the issue is not related to this thread. It will confuse other readers.

@nik202 ok