Cannot connect to host localhost:5055 ssl:default [Connection refused]

OS : OS X I installed RASA 1.6.0 then RASA X.

I understood well that you could launch the action server with the rasa run command. However RASA X is in charge of launching it.

I have access to RASA X on port 5002. When I am in talk with the bot and that my action must be launched, the console displays this message to me

Starting Rasa X in local mode... 🚀

The server is running at http://localhost:5002/login?username=me&password=XSxIfNZX0f6G

2020-01-07 22:32:05 **ERROR** rasa.core.actions.action - Failed to run custom action 'action_city'. Couldn't connect to the server at 'http://localhost:5055/webhook'. Is the server running? Error: Cannot connect to host localhost:5055 ssl:default [Connection refused]

2020-01-07 22:32:05 **ERROR** rasa.core.processor - Encountered an exception while running action 'action_city'. Bot will continue, but the actions events are lost. Please check the logs of your action server for more information.

I have the same problem on RASA, with the rasa shell command.

endpoints.yml

action_endpoint:
  url: "http://localhost:5055/webhook"

domain.yml

actions:
- action_city

stories.md

## Ask favorite City - save 1 city
* greet
    - utter_greet
* affirm
    - utter_favoris_ask_city
* city{"favoris_city": "Reims"}
    - action_city
* city{"favoris_city": "Reims"}
    - slot{"favoris_city": ["Reims"]}
    - utter_favoris_ask_second_city

I don’t know how to fix it. Any idea ?

“rasa run actions” starts the action server :thinking:

1 Like

It works @varunsapre10 ! I don’t know why I wan’t to use only rasa run:sweat_smile:

Can I start rasa actions server automaticaly when RASA X start ?

Thanks

Maybe. I haven’t tried it and I am unable to find anything like that on the internet. If possible you can search for the commands file in rasa and make changes there. This is just a guess.

anyone with the solution for this?

Hi @rashmi.metri

I completely forgot to give the solution. Have you tried the “rasa run actions” command?

Valentin

Hello! I am having the same issue (not connection to host) but when I try “rasa run actions” it never finishes. Does anyone know how could I solve this?

Thanks!

Hi @Sivsi I am having the same problem. Did you find out the solution?