Contextual assistant Tutorial not working as expected

I tried following the blog at Building contextual assistants with Rasa Forms

if a user specifies all preferences in the initial restaurant request, for example, ‘Book me a table for two at the Chinese restaurant’, the assistant will skip the questions about the cuisine and number of people.

But it is not extracting cuisine from the above statement. It seems to be extracting only num_people. It also does not echo back all the slots at the end of the conversation. See following conversation: rasa shell

WARNING: The TensorFlow contrib module will not be included in TensorFlow 2.0. For more information, please see:

2019-06-10 11:00:55 INFO root - Starting Rasa Core server on http://localhost:5005 2019-06-10 11:00:55.821296: I tensorflow/core/platform/] Your CPU supports instructions that this TensorFlow binary was not compiled to use: AVX2 FMA Bot loaded. Type a message and press enter (use ‘/stop’ to exit): Your input -> hi

Hello! I am restaurant search assistant! How can I help?

Your input -> book

what cuisine?

Your input -> Book me a table for two at the Chinese restaurant

what cuisine? [failed to extract cuisine from above statement]

Your input -> chinese

do you want to seat outside?

Your input -> yes

please provide additional preferences

Your input -> none

please give your feedback on your experience so far

Your input -> good

All done!

[failed to echo back responses]

Your input ->

sorry, I didn’t understand you, please try input something else

You can find the session with debug turned on at rasa Contextual assistant formbot with debug · GitHub

Hey @smcal75. I am looking into the tutorial and will get back to you once it’s updated :slight_smile:

Hi @smcal75. I struggle to replicate your issue. The cuisine is likely not to be extracted due to the NLU - I would check the examples used and add more phrases you would like your assistant to learn from there. With echoing responses - everything worked with the exact same conversation you had so I have a few questions about how you are running your bot:

  • Do you have a duckling server running?
docker run -p 8000:8000 rasa/duckling
  • Do you have the action server running?
rasa run actions&
rasa shell -m models --endpoints endpoints.yml
1 Like

@Juste Hi, I’m having a similar issue. But to start with I’ve got a complete beginner’s question. Your reply above states to start the action server with ‘rasa run actions&’

Does that literally mean to type an ampersand after the word actions? I’ve also seen it written like that other places in the documentation. If I do that then I get an error message saying that the ampersand character is not allowed.

If I start it without the ampersand then it runs but I have the same problem as the original message that it fails to echo back the collected entities after the ‘All Done’ message.

Thanks, Graham

Hi @graham. You should be able to pass the ampersand character, just make sure that you pass it all line rather than two separate commands. Let me know if that works.

To clarify: ampersand character here means that we are going to run two commands one after another