Changing the port for Rasa X UI with --rasa-x-port argument does not work?

tanja
(Dinesh) #1

I tried changing the port, to say 5003, for Rasa X UI with --rasa-x-port argument. But, it does not change the port and the UI still opens up in the default port of 5002. But, the regular Rasa server port, which by default runs on port 5005, does get changed with the --port command line argument. Am I missing something?

(Tanja Bergmann) #2

What version of Rasa X and Rasa are you using? You should use at least the version 0.19.1 for Rasa X along with Rasa version 1.0.7.

(Dinesh) #3

Along with Rasa version 1.0.7, I tried to upgrade the rasa-x into the latest version (pip install --upgrade rasa-x), also tried to force install the version 0.19.1 (pip install rasa-x==0.19.1), but it gives me the error:

ERROR: Could not find a version that satisfies the requirement rasa-x==0.19.1 (from versions: 0.0.0, 0.0.1, 0.0.2) ERROR: No matching distribution found for rasa-x==0.19.1

Any pointer for some resolution would be greatly appreciated. Thanks.

(Tanja Bergmann) #4

As described here you need to run

pip install rasa-x --extra-index-url https://pypi.rasa.com/simple

to install Rasa X.

(Dinesh) #5

I forgot that. Thanks.