How to run rasa interactive in a different port?


I can see that we can run the rasa server, shell command and rasa actions in different port using -p parameter. Is there anyway to run interactive learning in a different port other than 5005? In my server, there are some other services currently running on port 5005 and I don’t want to disturb them. Hence, trying to find a way to use some other ports for interactive learning. Please confirm.

Thank you, Anoop

Hey @anoopmohan :slight_smile:

You’re right, there isn’t currently a way to define this option. Would you be interested in contributing a fix adding this argument to rasa interactive? It shouldn’t be too complicated, I reckon you could just follow the -p argument of shell to figure out where the arg goes.

@erohmensing thank you for confirming it.

Not sure when will I get some time to look into the rasa code to add this fix, since I am handful of tasks with my current projects :slight_smile: But, will definitely try to add the fix , as soon as I get some free time.

Thank you, Anoop

Cool sounds good :rocket:

did we make any progress on this? i am also looking for same functionality.

No, I just checked and it still doesn’t look like an option, @abhi_bh_nlp would you be interested in contributing?

Yes i would be interested in contributing. Will have to get the understanding of code base. Will do that.

@abhi_bh_nlp I made an issue in the meantime and someone jumped on it – maybe you two can collaborate? add port argument for rasa interactive · Issue #4709 · RasaHQ/rasa · GitHub

Otherwise feel free to check out other issues on our project board: Contribute to Rasa · GitHub

We’d love to help you contribute to the project!

1 Like

Hi Ella,

Reaching out for a quick help. Whenver you get a chance, please check: Add X-XSS-Protection HTTP Header for RASA Core server request- http://<hostname>:5005.

Thank You.