change rasa action_endpoint port

Hello, I changed ports for action_endpoint and core_endpoint but when i execute run or action, actions and core still runs at default ports 5055 and 5005 respectively. endpoints.yml config is below

action_endpoint: url: “http://localhost:5056/webhook” tracker_store: store_type: mongod url: “mongodb://localhost:27017” db: rasa core_endpoint: url: “http://localhost:5006

action command rasa run --endpoints endpoints.yml --cors * --enable-api

rasa core command rasa run actions

please let me know whether we can define custom ports or not.

Yes, you need to add the option -p PORT or --port PORT to your commands rasa run and rasa run actions.

@Gehova thanks, it is working.

What is the use of this config if we need to pass the port via command line ?

In endpoints.yml, if I change the port, it does not take effect. Can someone please explain ? @Juste, shouldn’t changing port here be sufficient ?

action_endpoint:
  url: "http://localhost:5055/webhook"

Got it, change the config file to what you pass as port into the command line -

rasa run actions --port 9000 --debug

action_endpoint:
  url: http://localhost:9000/webhook

I think this should be explicitly documented.