Can't Install rasa-x

Using the command pip install rasa-x --extra-index-url Simple Index it keeps giving me an error and not sure how to fix it.

1 Like

Hi, Share the rasa version - rasa --version

1 Like

Rasa version : 3.0.3

cmd_2021-12-20_09-48-50

Rasa X doesn’t yet support v3 of Rasa Open Source so that will be why you’re having issues. You also need the latest version of pip installed it seems. Compatibility Matrix

I’m also struggling to get Rasa X working on the latest supported version of Rasa Open Source though https://forum.rasa.com/t/rasa-x-1-0-1-compatibility-issue-with-rasa-2-8-2-2-8-17-models