Can't customize the One-Line Deploy Script to works with my actions

Version: Rasa X 0.28.0

Hello !

I wanted to try Rasa so I made my own bot which can give some advice about running & weather. It works well on local, with rasa shell + rasa run actions.

I wanted to use Rasa X to improve it. I used curl -s | sudo bash.

The auto generated URL after The deployment is ready 🎉. You can now access Rasa X on this URL: didn’t work, I had to replace the IP address by localhost.

I made a repo on github with my files. At the beginning everything works well with Rasa X, excepted the training, I had to generate my model with the command rasa train on my shell and then push it to Rasa X and activate it.

Then I tried to talk with my bot and … the only answer I’ve received was :

There is no response text here And it loops on ...

I tried to debug with the flag -vv :

  • rasa run -vv -m ./models/20200508-124415.tar.gz --endpoints endpoints.yml --credentials credentials.yml --enable-api
  • rasa run actions -vv

But I didn’t see anything weird. I don’t understand very well the script used here curl -s | sudo bash, It’s opaque to me to debug it. (3.4 KB) config.yml (851 Bytes) credentials.yml (926 Bytes) domain.yml (2.1 KB) endpoints.yml (1.4 KB)

I’ve got an hint of what is not working.

First, when I used locally rasa/rasa_actions, I had to install spacy with fr_core_news_md.

I made a custom action server, push it to docker hub (donpeto/rasa:actions_weather_v0.4)

Dockerfile (782 Bytes)

Add those lines in my .zshrc

export ACTION_SERVER_IMAGE="donpeto/rasa"
export ACTION_SERVER_TAG="actions_weather_v0.4"

Launch a new terminal and execute again curl -s | sudo bash

It doesn’t fixe anything, I have the same problemes.

(My Rasa X version is now 0.28.2)