Can't connect to MS SQL with Rasa 1.0

Hi everyone,

I am trying to connect my bot to a Microsoft SQL Server, using these configurations:

type: SQL
dialect: "mssql+pyodbc"
db: "{ip address}/sqlexpress/{databaseName}"  # path to your db
username:  "username" #example value
password:  "password" 

but I am getting am error message:

rasa_core_1      |   File "/usr/local/lib/python3.6/site-packages/sqlalchemy/connectors/", line 37, in dbapi
rasa_core_1      |     return __import__("pyodbc")
rasa_core_1      | ModuleNotFoundError: No module named 'pyodbc'

I downloaded pyodbc using pip:

pip install pyodbc
Requirement already satisfied: pyodbc in 

I’ve also tried using dialect mssql+pymssql but got the same error:

rasa_core_1      |   File "/usr/local/lib/python3.6/site-packages/sqlalchemy/dialects/mssql/", line 61, in dbapi
rasa_core_1      |     module = __import__("pymssql")
rasa_core_1      | ModuleNotFoundError: No module named 'pymssql'

pymssql is also installed with pip:

pip install pymssql
Requirement already satisfied: pymssql in c:\users\admin\appdata\local\programs\python\python36\lib\site-packages

Is there something I am missing or doing wrong? I am using Rasa version 1.0.1

I am wondering, has anyone ever connected Rasa with a Microsoft SQL database before?

Could it be that you have two different python versions installed? Seems the sqlalchemy package is in a different path than the mssql package. So maybe you are using two different t python3.6 environments?

Hey , are you able to connect and save conversations to MSSQL !