Can't connect broker to Rabbit MQ in Rasa X

Rasa core and Rasa X are in different servers.

When trying to connect to a remote broker aka RabbitMQ in a a different instance (running from a Rasa X install script in Docker containers). All the params in the endpoints.yml in rasa are correct but by default always try to connect to localhost with its Private IP. 172.x.x.x not to the remote server with the Rabbit MQ container.

Hi @diegoluisr,

I guess that’s because your Rasa X instance is running in a local mode in your Docker container which is overwriting the endpoint settings. Could you also use our offical Rasa X images? Or what’s the motivation of building your own Rasa X image?

Thanks Tobias for answering,

I’m using the official Rasa X installation (bash script then docker-compose). The one that gives this error is the rasa core server running on a different instance, always trying to connect to localhost via private IP of the instance.

Mhm, can you please share your docker-compose file? Seems weird.