Cannot import Wit data

I was following instructions on how to import data from wit project:

I’m a windows user, so i ignored command

rm -r data/* mv /path/to/expressions.json data/

and moved json file to the data directory manually

then I tried

Step 3: Train your NLU model

To train a model using your Wit data, run:

rasa train nlu

I got the following error:

No NLU data given. Please provide NLU data in order to train a Rasa NLU model using the ‘–nlu’ argument.

What am I missing here?

Hi @emover. To be clear, the only NLU data inside the data/ directory in your project folder is your expressions.json file? And you are running rasa train nlu from within that project directory?

It should pick up the data directly if it is in this folder, but you can also try passing the data with the flag:

rasa train nlu --nlu relative/path/to/expressions.json

Hi, thank you for your reply. Yes, i have only 1 file in that directory I tried rasa train nlu --nlu data\expressions_1.json rasa train nlu --nlu data rasa train nlu --nlu data/expressions_1.json

it always giving me No NLU data given. Please provide NLU data in order to train a Rasa NLU model us ing the ‘–nlu’ argument.

Actually, I think the problem is in the json format. It won’t work from the imported file directly, it needs to be edited. I finally made it work

hm, I’m glad you got it to work, but that’s definitely not expected or desired! What did you have to change to get it to work? Perhaps with has changed their output format and we need to update our parser.

I am having the same issue here. How could I edit it in order to work?

Hi, I’m having the same issue and I think the format that needs to be changed is to include ‘rasa_nlu_data’ and ‘common_examples’ as keys.