Building a custom Action Server Image

Hello Everyone,

I have some extra dependecies in my actions.py file. So i build a DockerFile using this link Deploying a Rasa Open Source Assistant in Docker Compose.

Everything went file like creating a image build and push.

Then i used this link Docker-Compose Quick Install.

but when i try to do sudo docker-compose up -d it returns following error:

Pulling app (athenassaurav/rasa:12345)… ERROR: pull access denied for athenassaurav/rasa, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied

Please help me solve this.

Did you push this custom action server image to docker hub? And is it public?

I pushed and it is public. All commands as mentioned. Only when i tried docker-compose up -d it failed to pull and given that error. The repo on docker hub is public.

could you link me to the repo on docker hub?

Yeah. My repo link is : Docker Hub

Did you got time to see this please. I have followed each step as written in docs. Still not able to get container up and running

@athenasaurav I’m not sure this is a Rasa specific issue - can you try doing a manual docker pull athenasaurav/rasa:12345? I’m able to pull the image myself locally.

I dont have that windows version where i can pull this data. Let me try in vmware.

Can you share the content of that action server dockerfile please? which base-image do you use? do you “RUN rasa run actions” in the end?

Just faced the same issue. All I did was login to my docker account using the below command in SSH:

docker login --username <account_username> --password <account_password>

It gave me a success message “Login Succeeded”.

After this I was able to do “sudo docker-compose up -d” and the server got started.