Bot understanding but not responding


I’m new to Rasa and Python and I’m still trying to create something. But I have this problem where the bot understands what I’m saying but it won’t respond. What am I doing wrong here?

The grantaccess_folder_H has an answer

I get this error message on the console but I don’t understand why he responded my greet but won’t respond my grantacces_folder_H image

It seems like you have not added the endpoints. Did you uncomment or made any changes to endpoints.yml file?

   url: "http://localhost:5055/webhook"

Another issue can be if you actions server is running. Did you do rasa run actions if you have any actions written?

I did not uncomment or made any changes to the endpoints.yml. I tried to uncomment the webhook stuff and I got this rasa.core.actions.action

Failed to run custom action ‘liberar_pasta_H’. Couldn’t connect to the server at ‘http://localhost:5055/webhook’. Is the server running? Error: Cannot connect to host localhost:5055 ssl:default [Connection refused]

One thing that might be important, I’m running my rasa with a ubuntu vm (I tryed installing with windows but I was getting an error) behind a proxy.

But the thing is Why the utter_greet showed the message and the grantaccess_folder_H didn’t

Ok. I’m a idiot. The grantacess_folder_H should start with a “utter_” or it wont show…

Can you please explain it better? I’m getting the same error and don’t know how to solve…

@tiziano Basically, what you should keep in mind is that if you are sending a response from the bot, always save the response/template as ‘utter_xyz’. "utter_ "is the basic format for the bot to understand that this is a response.

1 Like