Weird behavior with rasa-x and "rasa train" command

Hi folks - I am getting a weird error when I try to run the “rasa train” command. I have installed Rasa-x and am trying to port a small (and working) chatbot model onto the new version today.

However, doing so fails and it blows up with errors like this:

2019-05-22 12:05:27 WARNING rasa.core.interpreter - Invalid to parse arguments in line ‘inform {“animal”:”cat”}’. Failed to decode parametersas a json object. Make sure the intentfollowed by a proper json object. Error: Expecting property name enclosed in double quotes: line 1 column 2 (char 1)

Since my input files are in markdown format (, I have no idea why the interpreter is trying to read them as json, and also the intent "inform (‘animal’:‘cat’) is not even in my chatbot, so I have no idea at all where Rasa-x is getting this from - all that I can say is that it looks like something from one of Juste’s demonstrations but it sure isnt anything that I have created.

Ideas, anybody?


Hm, the decoding as json shouldn’t be an issue, pretty sure it’s because it uses json.loads to turn strings like {"name": "ella"} from the slot action - slot{"name": "ella"} into dicts for parsing purposes. The inform thing is strange. I’ve done a project search for the word animal in both the rasa and rasa x codebases, and found nothing, so i really don’t think it can have come from us. You’re sure you can’t find any instances of it?

Just to check – does this error occur when training NLU or Core? You can see in the logs when each training is happening, or just see if rasa train core and rasa train nlu will each work.

Also, you say “with errors like this” – would you mind posting the whole stacktrace and formatting it with the three ticks (edited your original post as an example)?

Hi Ella, and thanks for your response.

I am not sure what was (and perhaps still is going on) but my uninstalling Anaconda3 has made this particular error go away. Clearly some sort of weird interaction happening, but I have not been able to figure it out (yet?).

Since Rasa-x abended in core training, I immediately suspected the file, but that animal/cat string in the “inform” that I reported is not in it, and never has been. I had already checked my own code base before I opened this thread, but I did not keep the stack trace unfortunately, so cannot append it.

The itself is a simple one that worked fine with my bot built for the earlier version of Rasa. It worked perfectly well there so cannot be too wrong or something would have fallen over before. It is possible that conda had something cached somewhere, and if so that would explain why removing conda has made the error go away…

So, problem solved, but I have no idea how or why. (!) Just in case, I have scanned my whole machine since removing Anaconda and I now do not have that string anywhere on my machine…

Since the error has gone, I am going to treat it as one of those weird random things that inevitably turn up on occasion, unless it reappears, in which case I will have to have the drains up.

Thanks again for your response.


Super strange! Glad you got the error to go away in any case. We’ll keep our eyes out for the issue too.