Rasa NLU parameter parsing

Greetings,

My goal is to use rasa-nlu with Microsoft bot-framework. For that i am trying to deploy Rasa-nlu using api & passing the exact arguments which are mentioned in the documents here. Still i am getting following response when i fire the post request for api

 {
    "version": "1.1.7",
    "status": "failure",
    "message": "An unexpected error occurred. Error: (400, 'ParsingError', 'An unexpected error occurred. Error: Agent needs to be prepared before usage. You need to set an interpreter, a policy ensemble as well as a tracker store.')",
    "reason": "ParsingError",
    "details": {},
    "help": null,
    "code": 500
}

Tried googling a bit. Also went through the forum as well but so far found nothing. Do guide me for the same. Thank you

Rasa version i am using is 1.1.7

Edit 1 July 23

I tried same implementation in 1.1.0 still error persists. But it works in version 1.0.7. Do state some workaround for the same or guide us for it please.

Edit 2

@Tanja Here are the details you asked

I am making the nlu model using the following command rasa train nlu. After the model is trained i am checking the model whether it is giving the response or not with following command rasa shell and i am getting the response with intent & entities including their probabilities. And finally enabling API for the same using

rasa run -m nlu-20190723-122339.tar.gz --enable-api

In console it displays that API is running on port 5005

2019-07-23 12:27:53 INFO root - Starting Rasa server on http://localhost:5005

When i send request to api via http call on this link http://localhost:5005/model/parse with following data {"text":"hi"}, it gives me the above error. There are no further error stack just empty response & the above text

1 Like

Getting same issue any one please help out. Thanks

What commands are you executing exactly? Can you please post them here? Also the full stack trace from the server logs would be helpful. Thanks.

Same problem here querying the api. I was working on previous versions of Rasa and I am using queries in a format compatible with the HTTP API specs within the doc.

Now, interestingly, for the same rasa version 1.1.7, it works if I install rasa from github.

Yes when i install it using Git it works fine & i can see that they did some pushes while we discussed question here. Tho this issue is solved i would like to have same implementation using pip as well. If that’s not much to ask

1 Like

hello im getting the same error even after the local host is running. please help me.

We are releasing a patch release today/tomorrow. So, the fix should be available via pip in version 1.1.8 soon.

Just another hint: If you run the command in debug mode (adding --debug), you should also see the full stacktrace, which should help to debug the problem.

@Tanja thank you for your reply. Yes i will update this as well by tomorrow.

Seems like in newer versions it is resolved. And quick commits in git after the question is proof of it. Thank you team @Rasa for doing it for us. Sorry bit late to mark this thread as done

Hi Akshay,

Did you integrate RASA NLU with botframework using restapi? how about the performance compare to sockets.