Voice assistant tutorial problem

I’m following this tutorial

and when I run rasa run actions --actions demo.actions. I receive the following error:

2020-02-15 19:37:19 ERROR    rasa_sdk.executor  - Failed to register package 'demo.actions'.
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/rasa_sdk/executor.py", line 206, in register_package
  File "/usr/local/lib/python3.7/site-packages/rasa_sdk/executor.py", line 191, in _import_submodules
    package = importlib.import_module(package)
  File "/usr/local/Cellar/python/3.7.5/Frameworks/Python.framework/Versions/3.7/lib/python3.7/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1006, in _gcd_import
  File "<frozen importlib._bootstrap>", line 983, in _find_and_load
  File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 677, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 728, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/Users/jonathanwheat/Code/RASA/rasa-demo/demo/actions.py", line 18, in <module>
    from demo.api import MailChimpAPI
  File "/Users/jonathanwheat/Code/RASA/rasa-demo/demo/api.py", line 3, in <module>
    from mailchimp3 import MailChimp
ModuleNotFoundError: No module named 'mailchimp3'

I verified there is a demo/actions.py file, so I’m unsure why it can’t find it.

Python 3.7.5 Rasa 1.7.2

Any ideas?

I’m going to talk to myself here for a bit.

I manually ran pip3 install mailchimp3 and got by that error and got ModuleNotFoundError: No module named 'algoliasearch'

I re-ran I ran pip install -e . and see

Running setup.py develop for rasa-demo
Successfully installed algoliasearch-2.1.0 beautifulsoup4-4.6.3 geographiclib-1.50 geopy-1.18.1 gspread-3.0.1 httplib2-0.17.0 oauth2client-4.1.3 pandas-0.24.2 pyasn1-0.4.8 pyasn1-modules-0.2.8 rasa-demo requests-2.21.0 rsa-4.0

However then saw ModuleNotFoundError: No module named 'algoliasearch'

Manually installed that and got ModuleNotFoundError: No module named 'gspread'

I realized I’m using pip3, so I ran pip3 install -e . and that went off and seems to have installed everything this time.