Unable to start Rasa X

Rasa Version : 2.0.2 Rasa SDK Version : 2.0.0 Rasa X Version : 0.33.0 Python Version : 3.7.6 Operating System : Windows-10-10.0.18362-SP0 Python Path : c:\users\singh\anaconda3\envs\installrasa\python.exe

tried rasa data validate

2020-10-29 14:03:58 INFO rasa.shared.utils.validation - The ‘version’ key is missing in the training data file C:\Users\singh\Downloads\rasa_chatbot-master\COVID-19_Tracker_Chatbot\domain.yml. Rasa Open Source will read the file as a version ‘2.0’ file. See Training Data Format. 2020-10-29 14:03:58 INFO rasa.validator - Validating intents… 2020-10-29 14:03:58 INFO rasa.validator - Validating uniqueness of intents and stories… 2020-10-29 14:03:58 INFO rasa.validator - Validating utterances… 2020-10-29 14:03:58 INFO rasa.validator - Story structure validation… Processed story blocks: 100%|████████████████████████████████████████████| 2/2 [00:00<00:00, 2006.36it/s, # trackers=1] 2020-10-29 14:03:58 INFO rasa.core.training.story_conflict - Considering the preceding 6 turns for conflict analysis. 2020-10-29 14:03:58 INFO rasa.validator - No story structure conflicts found.

when tried to open rasa x

Starting Rasa X in local mode… :rocket: Traceback (most recent call last): File “c:\users\singh\anaconda3\envs\installrasa\lib\site-packages\rasa\cli\x.py”, line 454, in run_locally args, project_path, args.data, token=rasa_x_token, config_path=config_path File “C:\Users\singh\AppData\Roaming\Python\Python37\site-packages\rasax\community\local.py”, line 225, in main project_path, data_path, session, args.port, config_path File “C:\Users\singh\AppData\Roaming\Python\Python37\site-packages\rasax\community\local.py”, line 162, in _initialize_with_local_data project_path, data_path, session, config_path=config_path File “c:\users\singh\anaconda3\envs\installrasa\lib\asyncio\base_events.py”, line 583, in run_until_complete return future.result() File “C:\Users\singh\AppData\Roaming\Python\Python37\site-packages\rasax\community\initialise.py”, line 342, in inject_files_from_disk username, File “C:\Users\singh\AppData\Roaming\Python\Python37\site-packages\rasax\community\initialise.py”, line 140, in inject_stories test_story_files, team, project_id, username, is_test=True File “C:\Users\singh\AppData\Roaming\Python\Python37\site-packages\rasax\community\services\story_service.py”, line 545, in save_stories_from_files is_test=is_test, File “C:\Users\singh\AppData\Roaming\Python\Python37\site-packages\rasax\community\services\story_service.py”, line 432, in save_stories story_string, filename, domain, is_test File “C:\Users\singh\AppData\Roaming\Python\Python37\site-packages\rasax\community\services\story_service.py”, line 337, in _extract_stories_markdown f"Invalid story format. Failed to parse ‘{story_text}’" rasa.shared.core.training_data.story_reader.story_reader.StoryParseError

please help

I have the same issue…!

Same issue here but I use rasa version 1.10.16

@SamS can you help with this as well or do I need to forward it to someone else?

1 Like

@fabrice-toussaint I’ll pass this on to someone who know more about this part of the codebase :slight_smile:

1 Like

@SamS awesome, thank you!

@singhabhishekiitkgp for me it is solved as due to migration there were some markdown test files in my test folder. However, when I removed RASA X would start. Hopefully this will help you as well, let me know okay?

EDIT: The markdown files could also be in other locations I guess.

Hey all, this is to do with an issue in the way markdown is parsed - we’ll be releasing a patch for this today/tomorrow! Keep an eye out :slight_smile:

1 Like

same issue is there any solution for …