Unable to install rasa-x locally

Hi I am using Rasa open source 2.8.25 which according to compatibility matrix requires Rasa 1.0.1; however when running the below, I get Rasa 1.1.1…

pip3 install rasa-x --extra-index-url https://pypi.rasa.com/simple

How can I install Rasa X appropriately?

pip install rasa-x==1.0.1 --extra-index-url https://pypi.rasa.com/simple

@itsjhonny when running that command I got this error:

from sanic.compat import open_async ImportError: cannot import name ‘open_async’ from ‘sanic.compat’

I currently have the following versions for sanic:






What should I do any idea?

So… i think you need to install rasa 2.8.25 again. When you maked pip3 install rasa-x --extra-index-url https://pypi.rasa.com/simple its updated some packages for rasa x 1.1.1 and broked rasa 2.8.25 packages

I recommend to try a fresh installation

@itsjhonny unfortunately I just tried to reinstall it, but I get the same error after running ‘rasa x’ on terminal…

Did you create another virtual environment?

@userRasa03 Hope this will help, please see the Warning Message bottom of the page: Installation Guide