Unable to connect to Rasa server remotely using IP address

Hi,

I have developed a bot (Rasa open source 2.8.13, Windows) and am able to connect to it using WebChat frontend. This setup works fine on the local server machine.

When I try to access it remotely, I am unable to reach the Rasa server. I have tried adding the port on which Rasa is started, to the allowed list in the inbound firewall rule on Windows. But, this doesn’t seem to help.

Command used to start Rasa: rasa run --cors “*” -p 10002 --debug rasa run actions -p 10003 --debug

Opened up port 10002 in Windows firewall settings.

Endpoints file looks like this:

action_endpoint: url: http://localhost:10003/webhook

core_endpoint: url: http://ip-addr:10002

I am unsure if core_endpoint option is valid but saw it on an older thread.

While the action server starts up on 0.0.0.0:10003, the core server starts on localhost:10002.

I am not using Docker or Rasa X to launch the instance but start the Rasa server in the Windows command line console. Also, I use an Nginx server which deploys a web app containing the index.html, which in turn, invokes the Rasa WebChat script that connects to the Rasa server.

Any pointers would be of immense help!

@srikanthnm I would be recommended seeing this thread and mentioned links: What is the best option to deploy rasa chatbot globally? hope this will solve your issue. But, in general, for an IP address you need secure HTTP i.e HTTPS and DNS on the server-side, otherwise test it using ngrok, just download the ngrok, authenticate the tokens and run ngrok http <port for rasa server i.e 10002>. If you have any doubt do let us know.

Thanks a lot for your response. As advised, I tried with ngrok on the Windows machine and was able to access the Rasa server.
I configured a similar setup on a Linux machine, opening up the port, and it worked fine even without using ngrok. So, Rasa seems to start at the specified port correctly.
Not sure if it is anything I am missing in setting up Windows firewall. Will keep you posted of any further developments.

@srikanthnm Great Srikanth, can I request to please close this thread as solution for other and for your own reference. Do update me if you having some issues.

I have an update for this issue. I configured my Windows firewall to allow the Rasa port. However, there was a block rule somewhere blocking Python connections. Removing it helped. Thanks a lot.