Unable to add bot into website

Trained RASA X bot in docker-compose. Unable to add my website.

@Prem24 what is your front end (chatbot) for the website?

Welcome to the forum.

I highly suggest you read How to ask a great question so that you can help us help you.

Hi Nik

We are trying to integrate our rasa x chat bot into our website by using socket.io we are unable to get response from bot

docker ps


Your second picture shows you did not change data-websocket-url. Change it to http://<server_ip>:5005/webhooks/rest/webhook.

Then, to verify the connection, using a tool like Postman, try sending a POST request to http://<server_ip>:5005/webhooks/rest/webhook with the following format:

    "sender": "Postman",
    "message": "Hello, World!"

Of course, the two machines (website and Rasa server) need to be connected. Either via LAN, Ethernet, or Internet, but you should be able to ping the website from the Rasa server or vice-versa.

Hello Chris

I have tried the method you added but got an error response in the postman

I have modified the request without giving a port number then it worked for me

Great :slight_smile:

What about changing the URL in the HTML? (Also don’t put the port there if that’s what worked for you)

I have added the same URL in the HTML script and tried but not working

Even I tried adding webhooks/rest/webhook in the HTML script but no use

Are your website and chatbot on the same server?

No …my website i am running that im my local system and rasa in cloud and we have communication between local system and server

@surendra10125 change the IP address with http://localhost:80 but you required DNS and SSL for socket URL OR you can you ngrok and paste the genrated HTTPs link. Good Luck!

Hi nik

can we access the bot without all these? i have gone through documentation after enabling socket.io we can get the data from the bot

@surendra10125 Is your bot is working now?

Yes nik my bot is working now and also can get the actions also

@surendra10125 the suggestions work, can you be specific? its not for me but for othe readers.


I am able to use my bot after login into rasa x UI but I am trying to add my bot to the website so that our team can check

when I have added a snippet in my HTML code my bot is not responding there

I am asking that your snippet is working on the website? yes or no?

yes snippet is working but not able to get data from bot

@surendra10125 what method you have used to install rasa x?

we have used docker-compose method

I have attached images above