Ubuntu - bash: rasa: command not found

Hi All,

On Ubuntu, I followed series of steps -

conda install python=3.6

conda create -n rasa python=3.6

source activate rasa

pip install rasa-x --extra-index-url https://pypi.rasa.com/simple

And when I execute rasa init I am getting following error -

bash: rasa: command not found

I tried conda list which shows rasa packages -

rasa-core 0.14.5 pypi_0 pypi

rasa-core-sdk 0.14.0 pypi_0 pypi

rasa-nlu 0.15.1 pypi_0 pypi

I checked PATH as well -


Could you check if I have missed anything ?

Could you try this?

Create a conda env with Python 3.6

Install Rasa open source:

pip3 install rasa

And then run:

rasa init

Instead of installing rasa x try this one by installing rasa open source and check if it is working.

(rasa-01) root@ip:/home/ubuntu# rasa init

bash: rasa: command not found

(rasa-01) root@ip:/home/ubuntu# python --version

Python 3.6.12 :: Anaconda, Inc.

I created another environment with 3.6, still facing same issue on Ubuntu

I am getting the same error on a Mac after installing rasa in a virtual environment.

Make sure you are using Python 3.6.x to 3.8.x, and NOT 3.9.