TypeError: run() missing 1 required positional argument: 'domain'

I am tried to run the custom action but getting this error…I

have looked in the rasa forum but could not found anything related to this…here are my custom action code and the error.

You have one extra parameter, slot_value, that should not be there.

If you want to get a slot’s value, use tracker.get_slot('slot_name')

1 Like

thanks @ChrisRahme it works fine now.

1 Like

@sdhaker2 If the end solution is by Chris (Thanks Buddy :wink:); then I am deleting the above post of mine and you also delete the same, so that there is no confusion for other users. Good Luck for your project!


okay and Thank you @nik202 for your feedback and time

1 Like

Glad to be of help.

By the way, your code can be greatly shortened and made more scalable (all these ifs/elifs can be removed).

Send it here if you want me to fix it :slight_smile:

Please put three backticks (```) above and under your code though when posting it here so that it formats properly. Or just send the file.

That is great but if else is no big deal for me…i can also remove those like create a dictionary. The main issue was already solved by you and i am very grateful for your help. If i have any problem i will definitely ask.

Thanks a lot

1 Like