Turn off specific debug message in RASA X

Hello, When I start my RASA X in debug mode, the log is littered constantly with this message:

"rasa.core.agent - No new model found at URL http://localhost:5002/api/projects/default/models/tags/production ** 2019-09-25 18:52:40 DEBUG rasa.core.agent - Requesting model from server http://localhost:5002/api/projects/default/models/tags/production…** ** 2019-09-25 18:52:40 DEBUG rasax.community.database.utils - Turned SQLite foreign key enforcement on.** ** 2019-09-25 18:52:40 DEBUG rasa.core.agent - Model server returned 204 status code, indicating that no new model is available…"**

This is getting repeated every 2 seconds which makes reading my logs and troubleshooting as a developer very difficult. Is there a flag we can set so we can either turn off this message or at least make it poll every 600 seconds for example ?

Many Thanks in advance,

Hi @maoun, at the moment there’s no way to update that interval. I agree that that would be useful, and is already possible when running rasa X in server mode on Docker. We’ll be looking into it

Thank you @ricwo …You’ll be doing us developers a great favor :slight_smile: