Telegram buttons not working with 2.0.2

Hey, I’m using rasa 2.0.2, and tried adding buttons integrated with telegram, just like it’s instructed in the rasa docs. But my data isn’t right, and I don’t know why. My domain file looks like:

  - buttons:
    - payload: /hi
      title: Hello
    - payload: /how_are_you
      title: How are you?
    button_type: vertical
    text: "Good afternoon!"

And I get the error: YamlValidationException: Failed to validate 'C:\Users\Me\Bots\bottest\domain.yml'. Please make sure the file is correct and all mandatory parameters are specified. Here are the errors found during validation: in C:\Users\Me\Bots\bottest\domain.yml:424: Key 'button_type' was not defined. Path: '/responses/utter_hi/0'

Are the buttons just not working, or am I missing something? Thanks

Hi @jessicaduque just remove the the line of button_type: vertical as follows

  • buttons:\
    • payload: /hi
      title: Hello\
    • payload: /how_are_you
      title: How are you?
      text: “Good afternoon!”
1 Like

It worked, thanks :slight_smile: