Stuck on setting up the tutorial

After following the steps for Installation for local development and running rasa init --template tutorial, now at Testing your money transfer flow.

rasa train gives me A Rasa Pro license is required. Please set the environmental variable RASA_PRO_LICENSE to a valid license string.

I did receive a license key, but don’t know the correct place to set this variable.

Hi @rkranendonk, you can set the RASA_PRO_LICENSE env var temporarily in your terminal, but it is recommended to set it persistently so that you don’t have to set it every time you run Rasa Pro.

Run the following in your terminal:

export RASA_PRO_LICENSE=<your-license-string>

See the docs here for further information: Licensing

1 Like

Thanks! 'rasa inspect` now opens the Inspector in my default browser.

However, I see a confused owl with “No flow is currently active”, and in the Flow pane, the only answer I get (apart from greetings) is “I am a bot, powered by Rasa”.

Also I have no data/flows.yml.

Please make sure you are running rasa-plus==3.7.7. You can check your version by running:

rasa --version

It could be that the rasa init --template tutorial command didn’t run completely due to the missing license previously. Try cleaning up the folder and running it again. You should then see the transfer_money flow in your data/flows.yml file.

Let me know if that works.

That took me a step further I guess.

I’ve got my RASA_PRO_LICENSE and my OPENAI_API_KEY set up

rasa train and rasa inspect now run without errors.

But if I enter ‘hello’ in the Rasa inspector it responds with “Sorry, I am having trouble with that. Please try again in a few minutes.”

The terminal shows the following error:

llm_command_generator.llm.error error=InvalidRequestError(message='The model gpt-4 does not exist or you do not have access to it. Learn more:', param=None, code='model_not_found', http_status=404, request_id=None)

My OpenAI API account has $5 remaining credits.


A good check to verify that the OPENAI_API_KEY is correctly set and valid for the model you’re using, default is gpt-4, is to first try it out without Rasa, and follow the steps of the openAI quickstart.

What OS are you running on?

If on MacOS, try using ’ ’ around the api-key, like:

export OPENAI_API_KEY='<your-api-key>'

I am indeed on MacOS. These are the steps I followed:

  1. put single quotes around the api-key in my .zshrc file.
  2. opened a new terminal window and checked if the key was set with echo $OPENAI_API_KEY
  3. followed the steps in the openAI QuickStart, including setting up and activating a virtual environment as recommended
  4. created and ran, which created a poem (cost me $0.01) – noticed that the output was maybe not configured correctly as intended LF’s where displayed as \n
  5. ran rasa train with no errors
  6. ran rasa inspect with no errors, but did get a DeprecationWarning for asyncio.wait()

Problem is still the same: The model gpt-4 does not exist or you do not have access to it.


Thank you for the detailed summary. I think we’re very close.

I suspect that you do not have access to the gpt-4 model, which is the default model that Rasa is configured with.

what model are you using in your ?

To use a different model in Rasa, you can modify the config.yml.

We solved it! was indeed configured for model="gpt-3.5-turbo".

Initially, after changing that to model="gpt-4", the ‘no access’ problem remained. The problem seems to be caused by the sub-optimal link between OpenAI’s billing logic and its model access. After buying some extra credits from OpenAI and letting OpenAI’s enormous intelligence work on that overnight, I now have access to gpt-4 and have successfully transferred large amounts of money to you guys!

Thanks for helping and I hope others will benefit from this thread.


As I’m using windows and not able to create a rasa pro project as i got the pro developer key but I don’t know how to start using the pro version locally.

I read the rasa docs but not understand properly i would like to hear from someone who already did it so that I may relate it.

please help me to start the pro version.