Stories are not working

My organisation is planning to adopting the rasa. Currently I’m learning RASA. So this query might be silly but I’m struggling from one and half weeks, while creating the stories. I’m just using very simple toy dataset like stories to make my hands dirty with RASA framework.

But while executing the stories my stories are not working as I fed in model. When I test it first time stories are working correctly as I made, but after in 2nd attempt for same story when I’m writing to shell CLI , then It’s taking the response/actions of another stories. Which is completely wrong.

Could you guys please help me where I’m doing the mistakes. I tried everything from my end but couldn’t be able to find out the real reason behind this.

I’m attaching some screenshots of my stories as well as the debugging images.


hi @AkshaySingh-DS it’s not very clear from your attachments what you are trying to achieve ? i assume you are referring to the scenario where user responses with a “no” on being asked “Did that help you” ?? And in this case I see it responded with some action related to ssh that you have configured.

Can you describe the flow clearly and attach the --debug output ? Also you stories.yml is not clear.

Hi @utsuk.prani, Sorry, let me also provide the actual stories.yml.

Bye the way rasa is not following the stories which I’ve designed, let me show you the debug output too, However I fixed the above issue by making the changes in config.yml file, I changed the max_history = 30, and augmentation_factor = 0 in MemoizationPolicy (this solution I found in forum), then above stories worked as the conversation I have designed.

But after creating the one more story again, things are messed up and I’m getting the same issue again, It is identifying the intent properly but why it is giving the response for another stories i.e. It is not following the stories conversation.

Above is the demo stories.yml I’ve. Issue is coming while adding the third story.

This is the complete demo Stories.yml while I have.

I fixed the above issue by making max_history = 40 in memoizationPolicy.

But I wanna understand the real concept behind it, like I went through the docs of policies but I didn’t understand the max_history and Augmentation_factor.

Could any one please explain me in a layman terms what is it ?