Spacy extractor is not working even mentioned in config file

Configuration for Rasa NLU.


language: en pipeline:

  • name: SpacyNLP model: “en_core_web_lg”
  • name: SpacyTokenizer
  • name: SpacyEntityExtractor Dimension: [“PERSON”]
  • name: SpacyFeaturizer pooling: mean
  • name: CRFEntityExtractor
  • name: RegexFeaturizer
  • name: CountVectorsFeaturizer analyzer: char_wb min_ngram: 1 max_ngram: 2
  • name: DIETClassifier epochs: 1

Configuration for Rasa Core.



  • name: MemoizationPolicy
  • name: TEDPolicy max_history: 5 epochs: 50
  • name: MappingPolicy
  • name: FormPolicy
  • name: “FallbackPolicy” nlu_threshold: 0.4 core_threshold: 0.3 fallback_action_name: “action_default_fallback”

this is the config file of my project

i am using form for extracting the person names email and so on

i am facing trouble even after installing the spacy model and space entity extractor for extracting person names

when I look into Rasa NLU shell spacy is not garbing the entities of name when i tried looking into the spacy model it etracted there in the website with entity name person can some one help me with this

Next message: harshith { “intent”: { “name”: “loan”, “confidence”: 0.14094895124435425 }, “entities”: [ { “entity”: “person_name”, “start”: 0, “end”: 8, “confidence_entity”: 0.9683254231128758, “value”: “harshith”, “extractor”: “CRFEntityExtractor” } ], “intent_ranking”: [ { “name”: “loan”, “confidence”: 0.14094895124435425 }, { “name”: “slotreset”, “confidence”: 0.13084132969379425 }, { “name”: “canthelp”, “confidence”: 0.1162768080830574 }, { “name”: “thankyou”, “confidence”: 0.11208485066890717 }, { “name”: “affirm”, “confidence”: 0.105034239590168 }, { “name”: “deny”, “confidence”: 0.09500378370285034 }, { “name”: “chitchat”, “confidence”: 0.08899442106485367 }, { “name”: “proceed”, “confidence”: 0.07901274412870407 }, { “name”: “inform”, “confidence”: 0.06890993565320969 }, { “name”: “unknow”, “confidence”: 0.06289295107126236 } ], “text”: “harshith” }

only the crfentity extractor is working in my cases i got know error while training the model

Hi Harshith,

There’s a good discussion of this topic here. It looks like the syntax is incorrect in your config.yml. It should be:

- name: SpacyEntityExtractor
  dimensions: ["PERSON"]


hey @stephens yeah i found out that the spacy has problem with the entity recognition of person_name even using the different pipelines it does not work

Basically i am from India the biggest problem Developing the chatbot with rasa is recognition of Indian names

i found out the way that is more successful is using a combination of CRFEntityExtractor and ‘spacy’ extractor it basically worked for me with lookup table just to be sure making the entity extractor more efficient

you need to make some changes in the actions because are using two entity extractor may return 2 entities if both entity are recognized

i will open new topic in the name Indian name recognition i will be explaining it very briefly in that topic

hey @sheggam_harshith…i saw your post and i also want the chatbot to extract a name …mine is Ethiopian name and for indian name how did it worked for you,please give me some explanination am also facing this problem