[Solved]Custom action throwing an exception


@ahson @akelad @Juste

So i am facing this issue and i have added endpoints.yml as follows :

action_endpoint: url: http://localhost:5055/webhook

I tried @ahson 's solution by updating endpoints.yml as follows :

action_endpoint: url: http://localhost:5055/webhook

core_endpoint: url: http://localhost:5005

Still no luck :frowning_face:

Anyone facing such issue ?

What does your endpoint.yml look like

Also what command are you using to

A. run the action server

b. run rasa core

You need to run both at the same time;

Check out the makefile in the moodbot example;

Thanks man , i had to add ‘endpontconfig’ which was missing . it’s solved :slight_smile:

can you please tell me how to pass --endpoint flag interactive learning

from rasa_core.agent import Agent

from rasa_core.train import online

from rasa_core.utils import EndpointConfig

endpoint = EndpointConfig(url=“http://localhost:5055/webhook”)

agent = Agent(“Add the usual parameters”, action_endpoint = endpoint )

data = agent.load_data(training_data_file)

agent.train(“usual parameters”)


Hope this serves your purpose :slight_smile:

Hi Abir,

I am currently running : python -m rasa_core_sdk.endpoint --actions actions in parallel to another prompt in which I am training my bot.

While doing this when I am calling custom action, it is throwing error

Can you please help.

make sure to correctly configure endpoint , Since the error code is 5xx it means custom action server is creating some problems . Otherwise , there could be some proxy issue

Hi Abir,

My endpoint.yml file is - action_endpoint: url: “http://localhost:5055/webhook” core_endpoint: url: “http://localhost:5055

Then also it is throwing 500 error.

nlu_interpreter = RasaNLUInterpreter(<nlu_model_path>)

action_endpoint = EndpointConfig(url=“http://localhost:5055/webhook”)

agent = Agent.load(<dialogue_model_path>, interpreter = nlu_interpreter, action_endpoint = action_endpoint)


Use the above to run bot and drop core_endpoint config that’s not necessary

It is working now.

Thanks for your help

Hi Abir,

I am currently training my bot and updating stories.md file using training online method.

Currently I am facing issue that bot is not able to identify brand as entity but all other entities it is identifying i.e. gender,color,product etc.

Can you please help on this.

Entity recognition will take more data as compared to intent classification.Just keep adding more data of a particular example type

Can you please tell me which file i need to change? and how?