Slack connector has to use proxy for outgoing requests in Docker

Hey there,

we are trying to use the slack connector in a Docker container in our Kubernetes cluster for communication. It is mandatory to use a proxy for outgoing requests. Is there any possibility to configure the connector to use a proxy? Or any other workaround to fit my needs?

Always receiving this Error Message: ERROR rasa.core.channels.slack - Exception when trying to handle message.

We´ve already tryed to set the ENV HTTP_PROXY=“” within our container via docker_compose.

Thanks for your help.

Hi Tobias and welcome to the forum.

I think you would need to use the proxy option on the python slack client library. Our Slack channel doesn’t currently support this option.

I opened issue #6123 for this request and included a link to the channel source code line where this would need to be added. Would you consider adding this?


Hey Greg,

thx for your response, sure i will give it a shot.

Best Tobi

Hi, We also need to send outgoing requests through proxy. Tried to apply the fix for issue #6123. it says only http proxies allowed. But our proxy configured with https as per mandate. Can this support https, it would be greatful or let me know in case of any alternatives


The problem exists in the httpclient used by the Slack Python SDK. As i read correct, the aiohttp-client does not support https directly. Mentioned here:

Well it is sad that you don’t support proxy option. I always use it today because there are a lot of creeps on internet and I do not want anyone to know my real location. I think that it is normal to do this now. There are some websites that are different in other countries, like Netflix and it is nice to see the difference. The one that you should always use a proxy on is TPB and good thing is that there is a list of proxies for it. When it goes down in one place it is not that hard to get it to work really, just use one from the list. That is why it is better to have a proxy as an option.

Best regards