Showing none in slot value

I’am trying to extract an entities name “c_id” with its same slot name from the user input.and created a custom action for filling the slot in my actions file. i encounter no error at training or executing the model in rasa shell or rasa x mode but i didn’t get the value in its slot. and showing none at the template in the terminal output and no slot value when running it in rasa x mode. as further i need to check that c_id in database to retrieve some information so got stuck up at this step. do help as i checked all related blogs and forum previous topic. also i’am uploading the images or my files for the reference.


Hi @rashmi_49,

Can you try to change this in your slot definition:

    type: any

And then train again and test the model in debug mode:

rasa shell --debug

Then, in the debug output that is written to the screen, can you make sure that the c_id entity is extracted, and that the c_id slot is filled?

This is all done by the NLU part of Rasa.

Once you confirmed that the c_id slot is filled, then you can extract it from the tracker as you do in your custom action, and overwrite the slot with a SlotSet event, as you are doing.

Thanks @Arjaan i tried changing slot type to any, and after training it i run the rasa shell in debug mode too. what i see is that entities extraction is working fine but slot is not filling yet. uploading the image of output screen for your reference, further inputs from your side would be helpful.

@rashmi_49, I see now what is going on. You have this in your slot definition:

auto_fill: False

That prevents the slot from being automatically set when an entity with the same name is extracted.

Please remove that line and then it should work.

See docs

1 Like

Thanks a lot @Arjaan that worked :slight_smile: !

1 Like