Save and quit issue with interactive training

Hi, I am pretty new to Rasa. I created a project based on the template project i get when I do ‘rasa init’.

I installed rasa with the following command:

‘pip install rasa-x --extra-index-url

The problem I have is that when I finish an interactive training and choose quit and save i get the following error:

Cancelled by user

? Do you want to stop?  Export & Quit

Unhandled exception in event loop:
  File "c:\users\bamit\appdata\local\programs\python\python37\lib\site-packages\prompt_toolkit\eventloop\", line 103, in _run_task
  File "c:\users\bamit\appdata\local\programs\python\python37\lib\site-packages\prompt_toolkit\eventloop\", line 115, in new_func
    return func(*a, **kw)
  File "c:\users\bamit\appdata\local\programs\python\python37\lib\site-packages\prompt_toolkit\application\", line 562, in read_from_input
  File "c:\users\bamit\appdata\local\programs\python\python37\lib\site-packages\prompt_toolkit\key_binding\", line 273, in process_keys
  File "c:\users\bamit\appdata\local\programs\python\python37\lib\site-packages\prompt_toolkit\key_binding\", line 180, in _process
    self._call_handler(matches[-1], key_sequence=buffer[:])
  File "c:\users\bamit\appdata\local\programs\python\python37\lib\site-packages\prompt_toolkit\key_binding\", line 323, in _call_handler
  File "c:\users\bamit\appdata\local\programs\python\python37\lib\site-packages\prompt_toolkit\key_binding\", line 78, in call
    return self.handler(event)
  File "c:\users\bamit\appdata\local\programs\python\python37\lib\site-packages\prompt_toolkit\shortcuts\", line 588, in _
  File "c:\users\bamit\appdata\local\programs\python\python37\lib\site-packages\prompt_toolkit\", line 1612, in validate_and_handle
    valid = self.validate(set_cursor=True)
  File "c:\users\bamit\appdata\local\programs\python\python37\lib\site-packages\prompt_toolkit\", line 1160, in validate
  File "c:\users\bamit\appdata\local\programs\python\python37\lib\site-packages\prompt_toolkit\", line 183, in validate
    return validator.validate(document)

Exception validate() takes 1 positional argument but 2 were given
Press ENTER to continue...

It is important to note that the project does work. I managed to create a model and everything works well. With the data I provided I managed to get to some nice results but I really need to get interactive training working properly.

*edit * I tried running interactive session of the template project I get when I run rasa init, but I got the same error.
Can you guys help me? Give me a direction to what may cause such a problem ? It looks like a problem with versions of some dependencies.

Hi @bamit. Can you tell me which Rasa version are you using?

[1.1.7] @Juste

Hey @capgos17. It is a bug that should have been fixed in 1.1.7. Could you please try to pull 1.1.8 and check if you still have this issue?

IS 1.1.8 a stable version? our whole project is based on 1.1.7 We don’t want to take risk by upgarding to a unstable version.