Run Rasa Docker image on your Raspberry Pi

I found a couple of attempts to install Rasa on a Raspberry Pi on this forum, but none for a recent release. So I took up the challenge, and as a result I can finally announce a Docker image for the latest Rasa version on ARMv7. Download the image (currently 1.10.56) with:

docker pull koenvervloesem/rasa

I only tried Rasa’s demo app (see Rhasspy’s forum), and training is quite slow, even on a Raspberry Pi 4, so I don’t know whether this will be useful, but I’d love to hear feedback.

Development happens here:

You can find there the build script and patches I used to build the image.

This image stays as close as possible to Rasa’s official Docker image. The only changes are added pre-built wheels for TensorFlow and TensorFlow Addons (which I had to build myself), some extra dependencies installed and the user ID changed to 1000 to align with the pi user on Raspberry Pi OS (Raspbian).


Hi Koen,

Thanks for posting here and for your work on a Pi image! @JulianGerhard @btotharye


Really thanks for building this docker image.

I have encountered an error when I trying to docker-compose up -d

ERROR: pull access denied for rasa, repository does not exist or may require 'docker login': denied: requested access to the resource is denied

I have tried to docker login and run the command again, but it result the same error.


My bad. It works perfectly now. I just realised that it is using rasa 1.10.10 now, so after changing the version from 1.10.5 to 1.10.10 in docker-compose.yml, it works.

Hey all, if you’d like to run Rasa 3.5.10 on your Raspberry Pi check out my post