Responses not found - Retrieval Actions


i started implementing several responses/retrieval actions following the steps in this link Retrieval Actions

When I retrain my model with rasa train it says: No response phrases found for feedback_general/good. Check training data files for a possible wrong intent name in NLU/NLG file

Do I need to link the file somewhere or put it in a special location?

Thanks a lot.

Hello @StephanieHohenberg,

You only need to put the in the data directory, where you also put the and for training the bot. How did you define the response in the ? Can you post an example here ?

Hi, yes I already added the I built it up like in the following. Sorry it is in german :wink:

## good feedback
* feedback_general/good
  - Das hört sich doch schonmal gut an.  
  - Das freut uns!
  - Vielen Dank für das Feedback.

## bad feedback
* feedback_general/bad
  - Schade


If i remember correctly, Rasa Retrieval Actions haven’t supported multiple responses yet. Can you leave only 1 response in the feedback_general/good, train again and see how it goes ?

Hi, I tried this too and it did not work. But anyway I decided to not implement it with retrieval actions anymore because it is still an experimental feature which I unfortunately could not get running. But thanks a lot for your help and effort :slight_smile:

I met the same problem. Anyone figure out the solution?

If there is a solution, i would also be happy to hear about.

Have you add Response selector in your config file

Hi. Please let me know if anyone solved it?

You must add a comment line at the end of response phrases list (this is stupid :D):

* chitchat/greeting
    -  hey

## hobby
1 Like

Thank you @quangnn1209