Response not matching with stories

Hi, I have defined story like this:

story 1

  • intent1
  • utter_intent1
  • intent2
  • utter_intent2
  • intent3
  • utter_intent3

story 2

  • intent4
  • utter_intent4

In my conversation, I tried:

  • User: intent1
  • Bot: utter_intent1
  • User: intent2
  • Bot: utter_intent2
  • User: intent4
  • Bot: utter_intent3

So, at the last step, the response by the bot should be “utter_intent4” but it is giving me response as “utter_intent3”. What could be the reason for that? I have almost 10 stories similar to story 1 and atleast 70-80 stories similar to story 2 in my bot. Till the time, all my stories were like story 2, the bot was working fine but now it’s not. Should I change some parameters in config.yml file or in any other file. I am not able to figure out the reason for that. Thanks

Hello @devesh,

before you start to messing with the pipelines, did you tried to use the shell (or RASA X interactive) to correct the response and retrain?

Perhaps it can add a few stories that will teach RASA the expected behavior and solve your case.