Resolving error

2019-05-23 16:05:18.746781: I tensorflow/core/platform/] Your CPU supports instructions that this TensorFlow binary was not compiled to use: AVX2 2019-05-23 16:05:19 ERROR rasa.core.agent - Failed to load policy and update agent. The previous model will stay loaded instead. Traceback (most recent call last): File “c:\users\harin\appdata\local\programs\python\python37\lib\site-packages\rasa\core\”, line 92, in _load_and_set_updated_model domain, policy_ensemble, fingerprint, interpreter, model_directory File “c:\users\harin\appdata\local\programs\python\python37\lib\site-packages\rasa\core\”, line 331, in update_model self.nlg.templates = domain.templates or [] AttributeError: ‘NoneType’ object has no attribute ‘templates’

What command are you using when you get this error?

i am using rasa x

Did you rasa init before, or are you in a directory for an old project? If so, is your domain called domain.yml and in the project directory?

yes i did rasa init…and yes my project directory has domain.yml file

I have the same thing.

i did:

Rasa train

all good. than i did:

rasa x

the web page loads and all. but if i talk to my bot no answer comes back and i filled files.

and in terminal i see the same error :point_up_2:

this error resolved when i made my local redis server live

i find it also :sleeping:

## intent:provide

:point_up_2: Put that in and it does not train the core and for some reason i did not see that happen. untill today i was looking in to the model train data .tar.gz and i did not find core there. fixed the issue by removing the

## provide_

and all works fine now.:sweat_smile::sweat_smile:

Could you please this in detail. I am getting the same error while running rasa x command

hey Man,

please run rasa train may be this will help you.

Thanks Ram for the help. Now the error is resolved.

1 Like