Resetting Tracker State but retaining Slot Values


Is there a way to do a tracker state reset but keep the slot values?

Also, I have an entity and a slot for that so the slot is filled when the said entity is extracted. I don’t want that entity to influence my conversation though and so I’ve set its type to be unfeaturized (or influence_conversation: false). However I can see that it still becomes part of the tracker as entity or user entity.

How can I make it not do that?

The session start action has this behaviour, is that something that would work?

Thank you for your response. I tried it but looks like its resetting the slots as well. Is that expected behaviour from a session start action?

I don’t think it should be, but let me double check.

Did you add this session configuration to your domain file? Domain

There’s a flag for carrying over slot values

Ahh right. I had set that to false because that’s what I wanted when a session start happens after the timeout I’ve set. Thanks, I think I know what to do about the issue I started with.

Could you help me figure something else out as well please? So I see that there had been a PR for the interpreter to be tracker aware ( How can I access the tracker in my custom nlu component now? And can I add something in my tracker while inside the said component as well? I’m kind of stuck here and any help would be appreciated, thanks!

Can I ask why you want to access the tracker from an NLU component?

I wish to know the sender id because I build some knowledge based on the user message that I later use in my actions. I need some way of saving that knowledge with the sender id.