Rasa X with Python 3.8.8 Installation Error

I am getting this error while installing rasa x, i am using windows 10, python 3.8.8, i tried with changing the path

    Running setup.py install for ujson ... error
    ERROR: Command errored out with exit status 1:
     command: 'c:\users\adarsh\pycharmprojects\bbott\venv\scripts\python.exe' -u -c 'import io, os, sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\U
sers\\ADARSH\\AppData\\Local\\Temp\\pip-install-ivkvp6pq\\ujson_18726b4fa1a4450daaef85be2b3128c4\\setup.py'"'"'; __file__='"'"'C:\\Users\\ADARSH\\AppDa
ta\\Local\\Temp\\pip-install-ivkvp6pq\\ujson_18726b4fa1a4450daaef85be2b3128c4\\setup.py'"'"';f = getattr(tokenize, '"'"'open'"'"', open)(__file__) if o
s.path.exists(__file__) else io.StringIO('"'"'from setuptools import setup; setup()'"'"');code = f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close
();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record 'C:\Users\ADARSH\AppData\Local\Temp\pip-record-ku2hm1jx\install-record.txt' --single
-version-externally-managed --compile --install-headers 'c:\users\adarsh\pycharmprojects\bbott\venv\include\site\python3.8\ujson'
         cwd: C:\Users\ADARSH\AppData\Local\Temp\pip-install-ivkvp6pq\ujson_18726b4fa1a4450daaef85be2b3128c4\
    Complete output (6 lines):
    Warning: 'classifiers' should be a list, got type 'filter'
    running install
    running build
    running build_ext
    building 'ujson' extension
    error: Microsoft Visual C++ 14.0 or greater is required. Get it with "Microsoft C++ Build Tools": https://visualstudio.microsoft.com/visual-cpp-bui
  Rolling back uninstall of ujson
  Moving to c:\users\adarsh\pycharmprojects\bbott\venv\lib\site-packages\ujson-4.2.0.dist-info\
   from C:\Users\ADARSH\PycharmProjects\bBott\venv\Lib\site-packages\~json-4.2.0.dist-info
  Moving to c:\users\adarsh\pycharmprojects\bbott\venv\lib\site-packages\ujson.cp38-win_amd64.pyd
   from C:\Users\ADARSH\AppData\Local\Temp\pip-uninstall-ngz4m0ng\ujson.cp38-win_amd64.pyd
ERROR: Command errored out with exit status 1: 'c:\users\adarsh\pycharmprojects\bbott\venv\scripts\python.exe' -u -c 'import io, os, sys, setuptools, t
okenize; sys.argv[0] = '"'"'C:\\Users\\ADARSH\\AppData\\Local\\Temp\\pip-install-ivkvp6pq\\ujson_18726b4fa1a4450daaef85be2b3128c4\\setup.py'"'"'; __fil
e__='"'"'C:\\Users\\ADARSH\\AppData\\Local\\Temp\\pip-install-ivkvp6pq\\ujson_18726b4fa1a4450daaef85be2b3128c4\\setup.py'"'"';f = getattr(tokenize, '"'
"'open'"'"', open)(__file__) if os.path.exists(__file__) else io.StringIO('"'"'from setuptools import setup; setup()'"'"');code = f.read().replace('"'"
'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record 'C:\Users\ADARSH\AppData\Local\Temp\pip-record-ku2h
m1jx\install-record.txt' --single-version-externally-managed --compile --install-headers 'c:\users\adarsh\pycharmprojects\bbott\venv\include\site\pytho
n3.8\ujson' Check the logs for full command output.

@AdarshTugao follow this thread please Windows installtion of Rasa x - #4

Can you confirm your rasa -version whilst activating the environment?

Hi , i am getting the same error , i am not using anaconda , i have python 3.8.8 and pycharm i started doing thr only , and rasa actions , and rasa I working , now I want to install rasa x getting the same error

could u assist me please if possible

@AdarshTugao That’s why I am here, can you please tell me which version you want to install? If you are looking for the latest version of Rasa X, then sorry there is no solution yet for this issue yet on the forum as per my knowledge.

@AdarshTugao confirm me you only want to install rasa x on local machine not on server?

this rasa x i am trying to install

@AdarshTugao you have install rasa on power shell of C, that can cause the issue.

@AdarshTugao please follow this thread: Rasa X runs with several Errors & Warnings - #2 by nik202

@AdarshTugao Did you able to solve this issue?

@AdarshTugao I guess you have solved this can you please close this thread? Thanks.