Rasa X Removing my Entity Synonyms

(Isaac Ellum) #1

My original model was train using a JSON file. However, when using RASA X it generates a MarkDown file with any new conversational data, then when I retrain it only looks at this new .MD file.

I got around this by just uploading my JSON file to RASA X and it all the data to the .MD file, however it ignored all of the synonyms. I tried to then add the synonyms manually into the .MD file, but every time I run RASA X it removed all the synonym values. Is there a way to add synonyms straight into RASA X?

(Akela Drissner) #2

@IsaacEllum could you create an issue for this on the rasa github repo? GitHub - RasaHQ/rasa: 💬 Open source machine learning framework to automate text- and voice-based conversations: NLU, dialogue management, connect to Slack, Facebook, and more - Create chatbots and voice assistants

(Ella Rohm-Ensing) #3

Hi @IsaacEllum, we are looking into the fact that your synonyms are being ignored. There is a way to add synonyms in rasa X: if you double click a word you are able to chose an entity that the word is a synonym of. 00