Rasa-x public docker image and experimental integrated version control

How do I enable experimental features in the public docker image for rasa-x? I have a file that I think should enable experimental features, specifically integrated version control.

/etc/rasa/config.json with contents:

{ “experimental”: “enabled”, “debug”: true }

And I run docker with this command line:

docker run -it -p 5002:5002 -p 5005:5005 -p 5055:5055 -e RASA_X_PASSWORD=password -v /Users/me/rasa-bot:/etc/rasa rasa/rasa-x:0.23.4

But I never have experimental features enabled. And I don’t even have the menu item giving me the popup to enable experimental features.

Thanks, Jason

HI there, Integrated Version Control is only implemented in Rasa X server mode. I believe the rasa/rasa-x image is for local mode.

Thank you Ella. That explains the issue. So to get around it, I’m trying to create my own image with Rasa X in server mode. I’ve put the instructions from https://rasa.com/docs/rasa-x/deploy/ into by Dockerfile and it builds but won’t run.

FROM ubuntu:18.04

RUN apt-get update && apt-get install -y curl sudo apt-utils wget \
 && sudo curl -L https://github.com/docker/compose/releases/download/1.25.0/docker-compose-`uname -s`-`uname -m` -o /usr/local/bin/docker-compose \
 && sudo chmod +x /usr/local/bin/docker-compose \
 && curl -sSL -o install.sh https://storage.googleapis.com/rasa-x-releases/0.23.5/install.sh \
 && sudo bash ./install.sh

EXPOSE 22 80 443 5002 5005

WORKDIR /etc/rasa

CMD ["/usr/local/bin/docker-compose", "up", "-d"]

It builds with a few warnings but seems to complete the build. But when I run it, I get this error:

ERROR: Couldn't connect to Docker daemon at http+docker://localhost - is it running?

If it's at a non-standard location, specify the URL with the DOCKER_HOST environment variable.

It looks like Docker isn’t properly starting inside the image.

Is the original Dockerfile which creates the DockerHub version of Rasa/Rasa-X image available? I can’t find it on GitHub. I think modifying that might return better results.

Hi @jwhitmer. You can’t run docker-compose within a docker container (or at least it’s not advisable). I wrote a blog post about automating the server install when I was working on a Jenkins setup.

You can ignore the import data discussion but the rest of the post should give you a good idea of automating the docker setup.

Thank you Greg. I’m reading over it. This looks very helpful. I’ll start in on it tonight.