Rasa X Not Loading Model

My understanding is you can load any model that works in Rasa Open Source into Rasa X. Is this correct?

I have a model that works for Rasa Open Source, but when I try to upload it into Rasa X Local Mode it fails to load the model and gives a message: Upload failed Something went wrong. Please try again.

I tried debug mode and I am not seeing any new information pop up in the log when it fails to load the model.

The same Rasa X instance will load a basic model that was built last week without issue, but it will not load any of the models that I created through Rasa Open Source.

I am using the following docker-compose.yml to run rasa x:

version: "3.4"

    image: rasa/rasa-x:latest
      - "5002:5002"
      - ./:/app
    command: rasa x --no-prompt -m model --debug

@csmyth76 I will suggest try only local mode first, if you are successfully able to upload the model, then its the issue of docker image and volume, he is not able to fetch the model. I hope you got my point?

In a model, we need to take model or models in command? In open source we take as models. I not use Rasa X as much.

The issue was the version of Rasa Open Source used to create the model.

I untarred both models and looked at the fingerprint.json file for each. The version for the model that worked was “2.6.3”. The version for the one that did not work was “2.2.9”

After I updated my Rasa Open Source and retrained the model, it loaded into Rasa X fine. pip install rasa --upgrade

I did not see ANYTHING in the logs when using --debug flag. That seems like an issue.