Rasa X can't connect to GitHub (Timeout Error)

I am running into an error with Rasa X, installed on a private server using the one-line deploy code. Whenever I try to connect with a key that is added to github and has right access I get a timeout error from the logs: WARNING:rasax.community.services.model_service:Could not run model discovery. /usr/local/lib/python3.7/site-packages/rasax/community/services/integrated_version_control/git_service.py:839: UserWarning: An error happened when trying to access 'git@github.com:HusamSadawi/test.git'. It seems you don't have to correct permissions for this repository. Please check if your credentials are correct and you have write permissions in the given repository. The error was: Cmd('git') failed due to: exit code(128) cmdline: git clone --depth=1 -v git@github.com:HusamSadawi/test.git /tmp/tmp57kfa8in stderr: 'Cloning into '/tmp/tmp57kfa8in'... ssh: connect to host github.com port 22: Connection timed out fatal: Could not read from remote repository. Please make sure you have the correct access rights and the repository exists. '.

I am almost convinced the error is with the SSH configuration, as my server had the same error until I edited the ssh config and added an entry for github.com, the problem is I don’t know how I would edit the config files inside the pod, specifically the /app/.ssh/ files. I tried accessing with shell but that accesses it as ‘rasa’ user and without root access to edit ssh files. Is there a way to do this? I’ve also tried using ssh links instead (ssh://git@github.com:442/…) with no luck, in that case I get the following error: Could not create directory '/root/.ssh'.