"rasa visualize" command not displaying intents?

I am looking to see the intents of the user’s input included in the tree visualization. https://arxiv.org/pdf/1712.05181.pdf on page 7 a tree has the intents recognized in the blue boxes. Whether I am using rasa visualize of rasa interactive I do not get this output in my trees. Is there a way to achieve this using another command or through making changes to the code?

This is what I want:

This is what I currently get:

Thanks in advance for any suggestions!

Hello @nat and welcome to the forum!

Right! Well over the period of time, rasa have changed alot and it functionalities, but I am sure you must be aware of these following commands for visualizations: Command Line Interface

Personally, I guess I have used the graph at the time of Rasa 1.10.x and after mirgating to Rasa 2.x and from .md to .yml I never used the Tree Graph Structure. I’m not sure is this functionality is still available as the case.

Summary: This feature I guess was used at the time there is seperate rasa-core, rasa-nlu and rasa-sdk. But now, we have only rasa and rasa-sdk. I guess this is the active bug as for your reference: https://github.com/RasaHQ/rasa/issues/7600

I will suggested and recommend to use rasa interactive with the visualization till the issue fixed in next release.

I hope this will help you to solve your issue and query. Good Luck!

@nat Is this still an issue for you or has the suggestion helped you?

Hi @nik202, The new Rasa 3 launch solved this! Thanks for checking in!

@nat glad it’s solved, can I request to please close this thread for other readers and for yourself.