RASA server 500 internal server error

hi, ive been trying call rasa server using http api from my android application and im getting 500 internal server error.

127.0.0.1 - - [2019-03-20 11:54:10] “POST /webhooks/rest/webhook HTTP/1.1” 500 444 0.014029 2019-03-20 11:55:30 ERROR flask.app - Exception on /webhooks/rest/webhook [POST] Traceback (most recent call last): File “C:\Users\bot2\lib\site-packages\flask\app.py”, line 2292, in wsgi_app response = self.full_dispatch_request() File “C:\Users\bot2\lib\site-packages\flask\app.py”, line 1815, in full_dispatch_request rv = self.handle_user_exception(e) File “C:\Usersl\bot2\lib\site-packages\flask_cors\extension.py”, line 161, in wrapped_function return cors_after_request(app.make_response(f(*args, **kwargs))) File “C:\Users\bot2\lib\site-packages\flask\app.py”, line 1718, in handle_user_exception reraise(exc_type, exc_value, tb) File “C:\Users\bot2\lib\site-packages\flask_compat.py”, line 35, in reraise raise value File “C:\Users\bot2\lib\site-packages\flask\app.py”, line 1813, in full_dispatch_request rv = self.dispatch_request() File “C:\Users\bot2\lib\site-packages\flask\app.py”, line 1799, in dispatch_request return self.view_functionsrule.endpoint File “c:\users\rasa_core\rasa_core\channels\channel.py”, line 361, in receive sender_id = self._extract_sender(request) File “c:\users\rasa_core\rasa_core\channels\channel.py”, line 329, in _extract_sender return req.json.get(“sender”, None) AttributeError: ‘NoneType’ object has no attribute ‘get’

Can anyone help me out on this issue.

The 500 Internal Server Error is the general catch all error when the server throws an exception. It is the error message when no more specific error message is suitable. It may be difficult to troubleshoot this error because it can be triggered out by many different issues. This error means there is a problem on the server side. However, there are often ways to quickly get around the problem:

  • Reload the web page.

  • Clear your browser’s cache

  • Delete your browser’s cookies

  • Or Come back later.

Hi @deepanshu

did you solve the issue? I have currently a similar problem trying to connect to rasa core running in docker. localhost:5000 and localhost:5005 both show the hello message, but once i try to talk to core i get the same error as you.

The error message on the server side:

And the error message from my call:

docker-compose.yml (1001 Bytes)

Hi @michaelh, ive solved this issue but there was a problem in my android UI and not rasa.

In your case you have entered “–header” in your CURL command which causes the 500 error.

Replace ‘header’ with ‘body’ in your command and that might work! When u POST, the message should go in the body and not the header. The “header” field is for credentials and authentication details basically and “body” is where we send the actual message.

Try using --body and let me know if u’ve resolved ur issue.

Hi @deepanshu

thanks for your suggestion :slight_smile:

I solved the issue by running the curl comand in git bash instead of cmd.