" rasa run -m models --enable-api --cors “*” --debug " not connecting to webchat

when I run " rasa run -m models --enable-api --cors “*” --debug " to connect with webchat local host I cannot see anything as I attached few screenshots. Thank you.

@JiteshGaikwad can you help me regarding this?

Can you attach the code of your testingchat.html file, I mean I want to see how you have connected with the socket.io

1 Like

Can you share the browser’s console logs?

1 Like

I don’t know how to share bro. can you tell where it will be?

Are you running the Rasa server and the Webchat on the same machine?

Can you tell which command are you using to start the Rasa server

1 Like

I just used rasa run -m models --enable-api --cors “*” --debug command to run the rasa webchat and I didn’t run any other commands.

From the error trace, I see the error is because of CORS and it happens at the server’s end if you haven’t enable the cors while you start the serve.

1 Like

How to enable cors bro

Are you using double quotes in the cors argument here, sometime it looks like double quotes but it’s not

rasa run -m models --enable-api --cors “*” --debug

1 Like

Same command I’m running bro?

I would suggest you to try out this repo code and check if you face the same issue.

1 Like

I installed npm but start command is showing error?

Hi @fede there is still problem with rasa webchat integration. If possible can you check this issue once here " rasa run -m models --enable-api --cors “*” --debug " not connecting to webchat